SEV1 - SL - 01 Network is down

Incident Report for CITY Furniture

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 16:52 EDT

Investigating

We are currently investigating this issue.
Posted Apr 17, 2025 - 14:42 EDT
This incident affected: Showroom Network Connectivity (CITY Showroom #01 - Fort Lauderdale - Primary).