SEV2: Store 14 Clearance Center Internet Outage

Incident Report for CITY Furniture

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 10:59 EDT

Investigating

Good morning, we are currently experiencing an internet outage at the Clearance Center located at our Tamarac HQ. Please note that this outage does not impact any other operations at the HQ or the main showroom. The issue has been escalated to our Network services team and we are working diligently to correct the issue as quickly as possible. We appreciate your patience and apologize for any inconvenience this may cause.
Posted Jun 16, 2026 - 09:48 EDT
This incident affected: Showroom Network Connectivity (CITY Showroom #03 - Tamarac - Primary, CITY Showroom #03 - Tamarac - Backup Circuit).