SEV2: Internet Connectivity Issues at Corporate Office

Incident Report for CITY Furniture

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 13:39 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2026 - 11:14 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 19:03 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 17:00 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 16:14 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2026 - 11:40 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 19:47 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 18:51 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 16:26 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 14:53 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 11:57 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 11:20 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 10:37 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 09:58 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 08:55 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 08:04 EDT

Update

We will be looking to deploy a fix at 6:00PM EST. Thank you for your patience.
Posted Jun 09, 2026 - 17:49 EDT

Identified

We will be looking to deploy a fix at 6:00PM EST. Thank you for your patience.
Posted Jun 09, 2026 - 14:16 EDT

Update

We are continuing to investigate this issue.
Posted Jun 09, 2026 - 13:37 EDT

Update

We are continuing to investigate this issue.
Posted Jun 09, 2026 - 13:05 EDT

Update

We are continuing to investigate this issue.
Posted Jun 09, 2026 - 11:50 EDT

Investigating

Good morning team. Please be advised that we are currently aware of an issue impacting the stability of the internet at the Tamarac corporate office. So far we are aware of issues in Marketing, IT, and Customer Care though other departments may also be affected. Users are likely to experiencing slow speeds, intermittent disconnections, and unstable internet. Our networking team is aware of the situation and currently working with our vendor to resolve the connection problem and get everyone back up and running. We will provide updates as they come in. Thank you for your patience and we apologize for any inconveneince this may cause.
Posted Jun 09, 2026 - 10:50 EDT
This incident affected: Corporate HQ Network.